Drupal Incorrect cache context on password reset page
CVE-2016-9450GHSA-98w5-wqp9-w466
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.2.3; drupal/drupal 8.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.0, < 8.2.3
- Fixed in
- 8.2.3
Packagist drupal/drupal
- Affected
- >= 8.0, < 8.2.3
- Fixed in
- 8.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98w5-wqp9-w466 lists affected ranges: Packagist drupal/core >=8.0 =8.0 <8.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2016-9450: 1.00% estimated exploitation activity in the next 30 days; percentile 63.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The user password reset form in Drupal 8.x before 8.2.3 allows remote attackers to conduct cache poisoning attacks by leveraging failure to specify a correct cache context.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-98w5-wqp9-w466
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-9450 Advisory: Drupal Incorrect cache context on password reset page IDs: CVE-2016-9450, GHSA-98w5-wqp9-w466 Record: https://patchnext.com/advisories/cve-2016-9450 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.2.3; drupal/drupal 8.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.0, < 8.2.3; fixed in 8.2.3 - Packagist drupal/drupal: affected >= 8.0, < 8.2.3; fixed in 8.2.3 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. - Packagist drupal/drupal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core, drupal/drupal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98w5-wqp9-w466 (GitHub-reviewed advisory GHSA-98w5-wqp9-w466 lists affected ranges: Packagist drupal/core >=8.0 =8.0 <8.2.3) Commands are suggestions: review each one before running it.
Loading voting…