Urllib3 Incorrect Certificate Validation
CVE-2016-9015GHSA-v4w5-p2hg-8fh6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (urllib3 1.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI urllib3
- Affected
- >= 1.17, <= 1.18
- Fixed in
- 1.18.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v4w5-p2hg-8fh6 lists affected ranges: PyPI urllib3 >=1.17 <1.18.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v4w5-p2hg-8fh6 lists affected ranges: PyPI urllib3 >=1.17 <=1.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2016-9015: 0.75% estimated exploitation activity in the next 30 days; percentile 55.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v4w5-p2hg-8fh6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v4w5-p2hg-8fh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-9015 Advisory: Urllib3 Incorrect Certificate Validation IDs: CVE-2016-9015, GHSA-v4w5-p2hg-8fh6 Record: https://patchnext.com/advisories/cve-2016-9015 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: urllib3 1.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI urllib3: affected >= 1.17, <= 1.18; fixed in 1.18.1 ## Suggested inspection (read-only) - `python -m pip show urllib3`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on urllib3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v4w5-p2hg-8fh6 (OSV record GHSA-v4w5-p2hg-8fh6 lists affected ranges: PyPI urllib3 >=1.17 <1.18.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v4w5-p2hg-8fh6 (GitHub-reviewed advisory GHSA-v4w5-p2hg-8fh6 lists affected ranges: PyPI urllib3 >=1.17 <=1.18) Commands are suggestions: review each one before running it.
Loading voting…