Apache Camel's Jackson and JacksonXML unmarshalling operation are vulnerable to Remote Code Execution attacks
CVE-2016-8749GHSA-vvjc-q5vr-52q6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-jackson 2.18.2, 2.17.5, 2.16.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-jackson
- Affected
- < 2.16.5>= 2.17.0, < 2.17.5>= 2.18.0, < 2.18.2
- Fixed in
- 2.17.5, 2.18.2, 2.16.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vvjc-q5vr-52q6 lists affected ranges: Maven org.apache.camel:camel-jackson >=0 =2.17.0 =2.18.0 <2.18.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-8749: 10.60% estimated exploitation activity in the next 30 days; percentile 95.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Camel's camel-jackson and camel-jacksonxml components are vulnerable to Java object de-serialisation vulnerability. Camel allows to specify such a type through the 'CamelJacksonUnmarshalType' property. De-serializing untrusted data can lead to security flaws as demonstrated in various similar reports about Java de-serialization issues. Mitigation: 2.16.x users should upgrade to 2.16.5, 2.17.x users should upgrade to 2.17.5, 2.18.x users should upgrade to 2.18.2. The JIRA tickets: https://issues.apache.org/jira/browse/CAMEL-10567 and https://issues.apache.org/jira/browse/CAMEL-10604 refers to the various commits that resovoled the issue, and have more details.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vvjc-q5vr-52q6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-8749 Advisory: Apache Camel's Jackson and JacksonXML unmarshalling operation are vulnerable to Remote Code Execution attacks IDs: CVE-2016-8749, GHSA-vvjc-q5vr-52q6 Record: https://patchnext.com/advisories/cve-2016-8749 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-jackson 2.18.2, 2.17.5, 2.16.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-jackson: affected < 2.16.5; >= 2.17.0, < 2.17.5; >= 2.18.0, < 2.18.2; fixed in 2.17.5, 2.18.2, 2.16.5 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-jackson: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-jackson. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vvjc-q5vr-52q6 (GitHub-reviewed advisory GHSA-vvjc-q5vr-52q6 lists affected ranges: Maven org.apache.camel:camel-jackson >=0 =2.17.0 =2.18.0 <2.18.2) Commands are suggestions: review each one before running it.
Loading voting…