Deserialization of Untrusted Data in Apache Brooklyn
CVE-2016-8744GHSA-9cqh-5x6g-wgm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.brooklyn:brooklyn 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.brooklyn:brooklyn
- Affected
- < 0.10.0
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cqh-5x6g-wgm9 lists affected ranges: Maven org.apache.brooklyn:brooklyn >=0 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-8744: 3.82% estimated exploitation activity in the next 30 days; percentile 90.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Brooklyn uses the SnakeYAML library for parsing YAML inputs. SnakeYAML allows the use of YAML tags to indicate that SnakeYAML should unmarshal data to a Java type. In the default configuration in Brooklyn before 0.10.0, SnakeYAML will allow unmarshalling to any Java type available on the classpath. This could provide an authenticated user with a means to cause the JVM running Brooklyn to load and run Java code without detection by Brooklyn. Such code would have the privileges of the Java process running Brooklyn, including the ability to open files and network connections, and execute system commands. There is known to be a proof-of-concept exploit using this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9cqh-5x6g-wgm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-8744 Advisory: Deserialization of Untrusted Data in Apache Brooklyn IDs: CVE-2016-8744, GHSA-9cqh-5x6g-wgm9 Record: https://patchnext.com/advisories/cve-2016-8744 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.brooklyn:brooklyn 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.brooklyn:brooklyn: affected < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - Maven org.apache.brooklyn:brooklyn: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.brooklyn:brooklyn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9cqh-5x6g-wgm9 (GitHub-reviewed advisory GHSA-9cqh-5x6g-wgm9 lists affected ranges: Maven org.apache.brooklyn:brooklyn >=0 <0.10.0) Commands are suggestions: review each one before running it.
Loading voting…