Moodle Unauthenticated Access
CVE-2016-8642GHSA-x32v-7qw8-cpq8
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.1.0, <= 3.1.2>= 3.0.0, <= 3.0.6>= 2.9.0, <= 2.9.8>= 2.8.0, <= 2.8.12>= 2.7.0, <= 2.7.16
- Fixed in
- 2.9.9, 3.1.3, 2.7.17, 3.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x32v-7qw8-cpq8 lists affected ranges: Packagist moodle/moodle >=3.1.0 =3.0.0 =2.9.0 =2.8.0 =2.7.0 <=2.7.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2016-8642: 1.20% estimated exploitation activity in the next 30 days; percentile 68.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x32v-7qw8-cpq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-8642 Advisory: Moodle Unauthenticated Access IDs: CVE-2016-8642, GHSA-x32v-7qw8-cpq8 Record: https://patchnext.com/advisories/cve-2016-8642 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moodle/moodle 3.1.3, 3.0.7, 2.9.9, 2.7.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.1.0, <= 3.1.2; >= 3.0.0, <= 3.0.6; >= 2.9.0, <= 2.9.8; >= 2.8.0, <= 2.8.12; >= 2.7.0, <= 2.7.16; fixed in 2.9.9, 3.1.3, 2.7.17, 3.0.7 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x32v-7qw8-cpq8 (GitHub-reviewed advisory GHSA-x32v-7qw8-cpq8 lists affected ranges: Packagist moodle/moodle >=3.1.0 =3.0.0 =2.9.0 =2.8.0 =2.7.0 <=2.7.16) Commands are suggestions: review each one before running it.
Loading voting…