MantisBT XSS through weak CSP when using Gravatar plugin
CVE-2016-7111GHSA-8vx9-hcvq-gfv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.0.0-beta.2, 1.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mantisbt/mantisbt
- Affected
- <= 1.3.0>= 2.0.0-beta.1, <= 2.0.0-beta.1
- Fixed in
- 1.3.1, 2.0.0-beta.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vx9-hcvq-gfv8 lists affected ranges: Packagist mantisbt/mantisbt >=0 =2.0.0-beta.1 <=2.0.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2016-7111: 1.00% estimated exploitation activity in the next 30 days; percentile 62.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MantisBT before 1.3.1 and 2.x before 2.0.0-beta.2 uses a weak Content Security Policy when using the Gravatar plugin, which allows remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8vx9-hcvq-gfv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-7111 Advisory: MantisBT XSS through weak CSP when using Gravatar plugin IDs: CVE-2016-7111, GHSA-8vx9-hcvq-gfv8 Record: https://patchnext.com/advisories/cve-2016-7111 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.0.0-beta.2, 1.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mantisbt/mantisbt: affected <= 1.3.0; >= 2.0.0-beta.1, <= 2.0.0-beta.1; fixed in 1.3.1, 2.0.0-beta.2 ## Suggested inspection (read-only) - Packagist mantisbt/mantisbt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mantisbt/mantisbt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8vx9-hcvq-gfv8 (GitHub-reviewed advisory GHSA-8vx9-hcvq-gfv8 lists affected ranges: Packagist mantisbt/mantisbt >=0 =2.0.0-beta.1 <=2.0.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…