invalid wildcard certificate validation check
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 6.0.0, < 6.7.0>= 4.0.0, < 4.6.0>= 5.0.0, < 6.0.0
- Fixed in
- 6.7.0, 4.6.0
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2016-7099 to 2016-09-27.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 19 lists CVE-2016-7099 affecting node >=6.0.0 =4.0.0 =5.0.0 <6.0.0 (no patch)
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-7099: 2.84% estimated exploitation activity in the next 30 days; percentile 86.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fix invalid wildcard certificate validation check whereby a TLS server may be able to serve an invalid wildcard certificate for its hostname due to improper validation of `*.` in the wildcard string. This is a high severity defect that would allow a malicious TLS server to serve an invalid wildcard certificate for its hostname and be improperly validated by a Node.js client. This is due to a flaw in the validation of *. in the wildcard name string.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:19
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:19
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-7099 Advisory: invalid wildcard certificate validation check IDs: CVE-2016-7099 Record: https://patchnext.com/advisories/cve-2016-7099 (revision 2, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: node 6.7.0, 4.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 6.0.0, < 6.7.0; >= 4.0.0, < 4.6.0; >= 5.0.0, < 6.0.0; fixed in 6.7.0, 4.6.0 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2016-7099 to 2016-09-27.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/19.json (Node.js security working group core entry 19 lists CVE-2016-7099 affecting node >=6.0.0 =4.0.0 =5.0.0 <6.0.0 (no patch)) Commands are suggestions: review each one before running it.
Loading voting…