Improper Neutralization of Input During Web Page Generation Apache ActiveMQ
CVE-2016-6810GHSA-5jg4-p78r-p5j3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-client 5.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-client
- Affected
- >= 5.0.0, <= 5.14.1
- Fixed in
- 5.14.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jg4-p78r-p5j3 lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <=5.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2016-6810: 6.09% estimated exploitation activity in the next 30 days; percentile 93.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5jg4-p78r-p5j3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-6810 Advisory: Improper Neutralization of Input During Web Page Generation Apache ActiveMQ IDs: CVE-2016-6810, GHSA-5jg4-p78r-p5j3 Record: https://patchnext.com/advisories/cve-2016-6810 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-client 5.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-client: affected >= 5.0.0, <= 5.14.1; fixed in 5.14.2 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5jg4-p78r-p5j3 (GitHub-reviewed advisory GHSA-5jg4-p78r-p5j3 lists affected ranges: Maven org.apache.activemq:activemq-client >=5.0.0 <=5.14.1) Commands are suggestions: review each one before running it.
Loading voting…