Cloud Foundry vulnerable to Cross-Site Request Forgery
CVE-2016-6637GHSA-4m8c-h7fr-gq5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 3.7.0, 3.4.4, 3.3.0.5, 2.7.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.cloudfoundry.identity:cloudfoundry-identity-server
- Affected
- >= 2.0.0, < 2.7.4.7>= 3.0.0, < 3.3.0.5>= 3.4.0, < 3.4.4>= 3.5.0, < 3.7.0
- Fixed in
- 3.4.4, 3.7.0, 2.7.4.7, 3.3.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4m8c-h7fr-gq5c lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=2.0.0 =3.0.0 =3.4.0 =3.5.0 <3.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2016-6637: 0.73% estimated exploitation activity in the next 30 days; percentile 54.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4m8c-h7fr-gq5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-6637 Advisory: Cloud Foundry vulnerable to Cross-Site Request Forgery IDs: CVE-2016-6637, GHSA-4m8c-h7fr-gq5c Record: https://patchnext.com/advisories/cve-2016-6637 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 3.7.0, 3.4.4, 3.3.0.5, 2.7.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected >= 2.0.0, < 2.7.4.7; >= 3.0.0, < 3.3.0.5; >= 3.4.0, < 3.4.4; >= 3.5.0, < 3.7.0; fixed in 3.4.4, 3.7.0, 2.7.4.7, 3.3.0.5 ## Suggested inspection (read-only) - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4m8c-h7fr-gq5c (GitHub-reviewed advisory GHSA-4m8c-h7fr-gq5c lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=2.0.0 =3.0.0 =3.4.0 =3.5.0 <3.7.0) Commands are suggestions: review each one before running it.
Loading voting…