Skip to content

← Actionable
Medium, CVSS 6.6amended

priority vulnerable to denial of service

CVE-2016-6580GHSA-h3q4-6j7f-r24c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (priority 1.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI priority

    Affected
    < 1.2.0
    Fixed in
    1.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2016-6580: 1.81% estimated exploitation activity in the next 30 days; percentile 78.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A HTTP/2 implementation built using any version of the Python priority library prior to version 1.2.0 could be targeted by a malicious peer by having that peer assign priority information for every possible HTTP/2 stream ID. The priority tree would happily continue to store the priority information for each stream, and would therefore allocate unbounded amounts of memory. Attempting to actually use a tree like this would also cause extremely high CPU usage to maintain the tree.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h3q4-6j7f-r24c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h3q4-6j7f-r24c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-6580

Advisory: priority vulnerable to denial of service
IDs: CVE-2016-6580, GHSA-h3q4-6j7f-r24c
Record: https://patchnext.com/advisories/cve-2016-6580 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: priority 1.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI priority: affected < 1.2.0; fixed in 1.2.0

## Suggested inspection (read-only)
- `python -m pip show priority`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on priority.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3q4-6j7f-r24c (OSV record GHSA-h3q4-6j7f-r24c lists affected ranges: PyPI priority >=0 <1.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h3q4-6j7f-r24c (GitHub-reviewed advisory GHSA-h3q4-6j7f-r24c lists affected ranges: PyPI priority >=0 <1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…