Drupal Saving user accounts can sometimes grant the user all roles
CVE-2016-6211GHSA-frqf-9qr4-6vxf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 7.44; drupal/drupal 7.44), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 7.0, < 7.44
- Fixed in
- 7.44
Packagist drupal/drupal
- Affected
- >= 7.0, < 7.44
- Fixed in
- 7.44
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-frqf-9qr4-6vxf lists affected ranges: Packagist drupal/core >=7.0 =7.0 <7.44
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-6211: 2.83% estimated exploitation activity in the next 30 days; percentile 86.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The User module in Drupal 7.x before 7.44 allows remote authenticated users to gain privileges via vectors involving contributed or custom code that triggers a rebuild of the user profile form.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-frqf-9qr4-6vxf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-6211 Advisory: Drupal Saving user accounts can sometimes grant the user all roles IDs: CVE-2016-6211, GHSA-frqf-9qr4-6vxf Record: https://patchnext.com/advisories/cve-2016-6211 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 7.44; drupal/drupal 7.44. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 7.0, < 7.44; fixed in 7.44 - Packagist drupal/drupal: affected >= 7.0, < 7.44; fixed in 7.44 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. - Packagist drupal/drupal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core, drupal/drupal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-frqf-9qr4-6vxf (GitHub-reviewed advisory GHSA-frqf-9qr4-6vxf lists affected ranges: Packagist drupal/core >=7.0 =7.0 <7.44) Commands are suggestions: review each one before running it.
Loading voting…