Skip to content

← Actionable
High, CVSS 7.5

phpMyAdmin vulnerable to Cross-Site Request Forgery

CVE-2016-5739GHSA-2p7v-jm8m-g3qq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 4.6.3, 4.4.15.7, 4.0.10.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpmyadmin/phpmyadmin

    Affected
    >= 4.0.10.0, < 4.0.10.16>= 4.4.15.0, < 4.4.15.7>= 4.6.0, < 4.6.3
    Fixed in
    4.6.3, 4.4.15.7, 4.0.10.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2016-5739: 2.95% estimated exploitation activity in the next 30 days; percentile 87.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Transformation implementation in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not use the no-referrer Content Security Policy (CSP) protection mechanism, which makes it easier for remote attackers to conduct CSRF attacks by reading an authentication token in a Referer header, related to libraries/Header.php.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2p7v-jm8m-g3qq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-5739

Advisory: phpMyAdmin vulnerable to Cross-Site Request Forgery
IDs: CVE-2016-5739, GHSA-2p7v-jm8m-g3qq
Record: https://patchnext.com/advisories/cve-2016-5739 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 4.6.3, 4.4.15.7, 4.0.10.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.0.10.0, < 4.0.10.16; >= 4.4.15.0, < 4.4.15.7; >= 4.6.0, < 4.6.3; fixed in 4.6.3, 4.4.15.7, 4.0.10.16

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2p7v-jm8m-g3qq (GitHub-reviewed advisory GHSA-2p7v-jm8m-g3qq lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.0.10.0 =4.4.15.0 =4.6.0 <4.6.3)

Commands are suggestions: review each one before running it.

Loading voting…