Improper Limitation of a Pathname to a Restricted Directory in JCraft JSch
CVE-2016-5725GHSA-q446-82vq-w674
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.jcraft:jsch 0.1.54), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.jcraft:jsch
- Affected
- <= 0.1.53
- Fixed in
- 0.1.54
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q446-82vq-w674 lists affected ranges: Maven com.jcraft:jsch >=0 <=0.1.53
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2016-5725: 24.14% estimated exploitation activity in the next 30 days; percentile 97.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in JCraft JSch before 0.1.54 on Windows, when the mode is ChannelSftp.OVERWRITE, allows remote SFTP servers to write to arbitrary files via a ..\ (dot dot backslash) in a response to a recursive GET command.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q446-82vq-w674
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-5725 Advisory: Improper Limitation of a Pathname to a Restricted Directory in JCraft JSch IDs: CVE-2016-5725, GHSA-q446-82vq-w674 Record: https://patchnext.com/advisories/cve-2016-5725 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.jcraft:jsch 0.1.54. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.jcraft:jsch: affected <= 0.1.53; fixed in 0.1.54 ## Suggested inspection (read-only) - Maven com.jcraft:jsch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.jcraft:jsch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q446-82vq-w674 (GitHub-reviewed advisory GHSA-q446-82vq-w674 lists affected ranges: Maven com.jcraft:jsch >=0 <=0.1.53) Commands are suggestions: review each one before running it.
Loading voting…