Skip to content

← Actionable
High, CVSS 7.5

Ruby-saml allows attackers to perform XML signature wrapping attacks

CVE-2016-5697GHSA-36p7-xjw8-h6f2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ruby-saml 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems ruby-saml

    Affected
    < 1.3.0
    Fixed in
    1.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2016-5697: 1.21% estimated exploitation activity in the next 30 days; percentile 68.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ruby-saml prior to version 1.3.0 is vulnerable to an XML signature wrapping attack in the specific scenario where there was a signature that referenced at the same time 2 elements (but past the scheme validator process since 1 of the element was inside the encrypted assertion). ruby-saml users must update to 1.3.0, which implements 3 extra validations to mitigate this kind of attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-36p7-xjw8-h6f2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-5697

Advisory: Ruby-saml allows attackers to perform XML signature wrapping attacks
IDs: CVE-2016-5697, GHSA-36p7-xjw8-h6f2
Record: https://patchnext.com/advisories/cve-2016-5697 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ruby-saml 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems ruby-saml: affected < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- RubyGems ruby-saml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ruby-saml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-36p7-xjw8-h6f2 (GitHub-reviewed advisory GHSA-36p7-xjw8-h6f2 lists affected ranges: RubyGems ruby-saml >=0 <1.3.0)

Commands are suggestions: review each one before running it.

Loading voting…