PHP JOSE Library by Gree Inc. Uses a Broken or Risky Cryptographic Algorithm
CVE-2016-5431GHSA-xm5f-hc9r-76f3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gree/jose 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist gree/jose
- Affected
- < 2.2.1
- Fixed in
- 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xm5f-hc9r-76f3 lists affected ranges: Packagist gree/jose >=0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2016-5431: 0.95% estimated exploitation activity in the next 30 days; percentile 61.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PHP JOSE Library by Gree Inc. prior to 2.2.1 is vulnerable to key confusion/algorithm substitution in the JWS component resulting in bypassing the signature verification via crafted tokens.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xm5f-hc9r-76f3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-5431 Advisory: PHP JOSE Library by Gree Inc. Uses a Broken or Risky Cryptographic Algorithm IDs: CVE-2016-5431, GHSA-xm5f-hc9r-76f3 Record: https://patchnext.com/advisories/cve-2016-5431 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gree/jose 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist gree/jose: affected < 2.2.1; fixed in 2.2.1 ## Suggested inspection (read-only) - Packagist gree/jose: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gree/jose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xm5f-hc9r-76f3 (GitHub-reviewed advisory GHSA-xm5f-hc9r-76f3 lists affected ranges: Packagist gree/jose >=0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…