Moodle Does Not Escape Characters In Email Headers
CVE-2016-5013GHSA-2hh3-jmv8-5fmx
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.0, <= 3.0.4>= 2.9, <= 2.9.6>= 2.8, <= 2.8.12>= 2.7, <= 2.7.14>= 3.1, < 3.1.1
- Fixed in
- 2.9.7, 3.1.1, 2.7.15, 3.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2hh3-jmv8-5fmx lists affected ranges: Packagist moodle/moodle >=3.0 =2.9 =2.8 =2.7 =3.1 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2016-5013: 1.06% estimated exploitation activity in the next 30 days; percentile 64.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Moodle 2.x and 3.x, text injection can occur in email headers, potentially leading to outbound spam.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2hh3-jmv8-5fmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-5013 Advisory: Moodle Does Not Escape Characters In Email Headers IDs: CVE-2016-5013, GHSA-2hh3-jmv8-5fmx Record: https://patchnext.com/advisories/cve-2016-5013 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moodle/moodle 3.1.1, 3.0.5, 2.9.7, 2.7.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.0, <= 3.0.4; >= 2.9, <= 2.9.6; >= 2.8, <= 2.8.12; >= 2.7, <= 2.7.14; >= 3.1, < 3.1.1; fixed in 2.9.7, 3.1.1, 2.7.15, 3.0.5 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2hh3-jmv8-5fmx (GitHub-reviewed advisory GHSA-2hh3-jmv8-5fmx lists affected ranges: Packagist moodle/moodle >=3.0 =2.9 =2.8 =2.7 =3.1 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…