Skip to content

← Actionable
High, CVSS 7.5

CakePHP allows remote attackers to spoof their IP

CVE-2016-4793GHSA-j8p3-8m69-2hqq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 3.2.5, 3.1.12, 3.0.17, 2.8.2, 2.7.11, 2.6.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/cakephp

    Affected
    >= 1.2.0, < 2.6.13>= 2.7.0-rc1, < 2.7.11>= 2.8.0-rc1, < 2.8.2>= 3.0.0-rc1, < 3.0.17>= 3.1.0-beta1, < 3.1.12>= 3.2.0-rc1, < 3.2.5
    Fixed in
    2.6.13, 2.7.11, 3.2.5, 3.1.12, 3.0.17, 2.8.2

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-j8p3-8m69-2hqq lists affected ranges: Packagist cakephp/cakephp >=1.2.0 =2.7.0-rc1 =2.8.0-rc1 =3.0.0-rc1 =3.1.0-beta1 =3.2.0-rc1 <3.2.5

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2016-4793: 5.15% estimated exploitation activity in the next 30 days; percentile 92.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j8p3-8m69-2hqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-4793

Advisory: CakePHP allows remote attackers to spoof their IP
IDs: CVE-2016-4793, GHSA-j8p3-8m69-2hqq
Record: https://patchnext.com/advisories/cve-2016-4793 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 3.2.5, 3.1.12, 3.0.17, 2.8.2, 2.7.11, 2.6.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/cakephp: affected >= 1.2.0, < 2.6.13; >= 2.7.0-rc1, < 2.7.11; >= 2.8.0-rc1, < 2.8.2; >= 3.0.0-rc1, < 3.0.17; >= 3.1.0-beta1, < 3.1.12; >= 3.2.0-rc1, < 3.2.5; fixed in 2.6.13, 2.7.11, 3.2.5, 3.1.12, 3.0.17, 2.8.2

## Suggested inspection (read-only)
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j8p3-8m69-2hqq (GitHub-reviewed advisory GHSA-j8p3-8m69-2hqq lists affected ranges: Packagist cakephp/cakephp >=1.2.0 =2.7.0-rc1 =2.8.0-rc1 =3.0.0-rc1 =3.1.0-beta1 =3.2.0-rc1 <3.2.5)

Commands are suggestions: review each one before running it.

Loading voting…