Skip to content

← Actionable
Medium, CVSS 5.4amended

OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability

CVE-2016-4428GHSA-grm6-x6mr-q3cv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (horizon 9.1.0, 8.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI horizon

    Affected
    <= 8.0.1>= 9.0.0, <= 9.0.1
    Fixed in
    8.0.2, 9.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2016-4428: 2.08% estimated exploitation activity in the next 30 days; percentile 81.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-grm6-x6mr-q3cv

  2. Revision 1 · created ·

    Published from osv record GHSA-grm6-x6mr-q3cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-4428

Advisory: OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability
IDs: CVE-2016-4428, GHSA-grm6-x6mr-q3cv
Record: https://patchnext.com/advisories/cve-2016-4428 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: horizon 9.1.0, 8.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI horizon: affected <= 8.0.1; >= 9.0.0, <= 9.0.1; fixed in 8.0.2, 9.1.0

## Suggested inspection (read-only)
- `python -m pip show horizon`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on horizon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-grm6-x6mr-q3cv (OSV record GHSA-grm6-x6mr-q3cv lists affected ranges: PyPI horizon >=0 =9.0.0 <9.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-grm6-x6mr-q3cv (GitHub-reviewed advisory GHSA-grm6-x6mr-q3cv lists affected ranges: PyPI horizon >=0 =9.0.0 <=9.0.1)

Commands are suggestions: review each one before running it.

Loading voting…