Skip to content

← Actionable
High, CVSS 7.5

Symphony Denial of Service Via Overlong Usernames

CVE-2016-4423GHSA-whgv-8cg3-7hcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 3.0.6, 2.8.6, 2.7.13, 2.3.41; symfony/security-http 3.0.6, 2.8.6, 2.7.13, 2.3.41; symfony/security 3.0.6, 2.8.6, 2.7.13, 2.3.41), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.3.0, < 2.3.41>= 2.4.0, < 2.7.13>= 2.8.0, < 2.8.6>= 3.0.0, < 3.0.6
    Fixed in
    2.8.6, 3.0.6, 2.7.13, 2.3.41
  • Packagist symfony/security-http

    Affected
    >= 2.3.0, < 2.3.41>= 2.4.0, < 2.7.13>= 2.8.0, < 2.8.6>= 3.0.0, < 3.0.6
    Fixed in
    2.8.6, 3.0.6, 2.7.13, 2.3.41
  • Packagist symfony/security

    Affected
    >= 2.3.0, < 2.3.41>= 2.4.0, < 2.7.13>= 2.8.0, < 2.8.6>= 3.0.0, < 3.0.6
    Fixed in
    2.8.6, 3.0.6, 2.7.13, 2.3.41

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-whgv-8cg3-7hcm lists affected ranges: Packagist symfony/security-http >=2.3.0 =2.4.0 =2.8.0 =3.0.0 =2.3.0 =2.4.0 =2.8.0 =3.0.0 =2.3.0 =2.4.0 =2.8.0 =3.0.0 <3.0.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2016-4423: 1.86% estimated exploitation activity in the next 30 days; percentile 79.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The attemptAuthentication function in Component/Security/Http/Firewall/UsernamePasswordFormAuthenticationListener.php in Symfony before 2.3.41, 2.7.x before 2.7.13, 2.8.x before 2.8.6, and 3.0.x before 3.0.6 does not limit the length of a username stored in a session, which allows remote attackers to cause a denial of service (session storage consumption) via a series of authentication attempts with long, non-existent usernames.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-whgv-8cg3-7hcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-4423

Advisory: Symphony Denial of Service Via Overlong Usernames
IDs: CVE-2016-4423, GHSA-whgv-8cg3-7hcm
Record: https://patchnext.com/advisories/cve-2016-4423 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 3.0.6, 2.8.6, 2.7.13, 2.3.41; symfony/security-http 3.0.6, 2.8.6, 2.7.13, 2.3.41; symfony/security 3.0.6, 2.8.6, 2.7.13, 2.3.41. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.3.0, < 2.3.41; >= 2.4.0, < 2.7.13; >= 2.8.0, < 2.8.6; >= 3.0.0, < 3.0.6; fixed in 2.8.6, 3.0.6, 2.7.13, 2.3.41
- Packagist symfony/security-http: affected >= 2.3.0, < 2.3.41; >= 2.4.0, < 2.7.13; >= 2.8.0, < 2.8.6; >= 3.0.0, < 3.0.6; fixed in 2.8.6, 3.0.6, 2.7.13, 2.3.41
- Packagist symfony/security: affected >= 2.3.0, < 2.3.41; >= 2.4.0, < 2.7.13; >= 2.8.0, < 2.8.6; >= 3.0.0, < 3.0.6; fixed in 2.8.6, 3.0.6, 2.7.13, 2.3.41

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-http: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-http, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-whgv-8cg3-7hcm (GitHub-reviewed advisory GHSA-whgv-8cg3-7hcm lists affected ranges: Packagist symfony/security-http >=2.3.0 =2.4.0 =2.8.0 =3.0.0 =2.3.0 =2.4.0 =2.8.0 =3.0.0 =2.3.0 =2.4.0 =2.8.0 =3.0.0 <3.0.6)

Commands are suggestions: review each one before running it.

Loading voting…