npm Token Leak in npm
CVE-2016-3956GHSA-m5h6-hr3q-22h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (npm 3.8.3, 2.15.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm npm
- Affected
- <= 2.15.0>= 3.0.0, <= 3.8.2
- Fixed in
- 2.15.1, 3.8.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m5h6-hr3q-22h5 lists affected ranges: npm npm >=0 =3.0.0 <3.8.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m5h6-hr3q-22h5 lists affected ranges: npm npm >=0 =3.0.0 <=3.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-3956: 5.46% estimated exploitation activity in the next 30 days; percentile 92.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of the npm package include the bearer token of the logged in user in every request made by the CLI, even if the request is not directed towards the user's active registry. An attacker could create an HTTP server to collect tokens, and by various means including but not limited to install scripts, cause the npm CLI to make a request to that server, which would compromise the user's token. This compromised token could be used to do anything that the user could do, including publishing new packages. Recommendation 1. Update npm with npm install npm@latest -g 2. Revoke your Tokens 3. Enable Two-Factor Authentication
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m5h6-hr3q-22h5
- Revision 1 · created ·
Published from osv record GHSA-m5h6-hr3q-22h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-3956 Advisory: npm Token Leak in npm IDs: CVE-2016-3956, GHSA-m5h6-hr3q-22h5 Record: https://patchnext.com/advisories/cve-2016-3956 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: npm 3.8.3, 2.15.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm npm: affected <= 2.15.0; >= 3.0.0, <= 3.8.2; fixed in 2.15.1, 3.8.3 ## Suggested inspection (read-only) - `npm ls npm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on npm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m5h6-hr3q-22h5 (OSV record GHSA-m5h6-hr3q-22h5 lists affected ranges: npm npm >=0 =3.0.0 <3.8.3 (fixed)) - Verified: https://github.com/advisories/GHSA-m5h6-hr3q-22h5 (GitHub-reviewed advisory GHSA-m5h6-hr3q-22h5 lists affected ranges: npm npm >=0 =3.0.0 <=3.8.2) Commands are suggestions: review each one before running it.
Loading voting…