Privilege Elevation in runc
CVE-2016-3697GHSA-q3j5-32m5-58c2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/opencontainers/runc 0.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/opencontainers/runc
- Affected
- < 0.1.0
- Fixed in
- 0.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3j5-32m5-58c2 lists affected ranges: Go github.com/opencontainers/runc >=0 <0.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-3697: 0.39% estimated exploitation activity in the next 30 days; percentile 33.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
libcontainer/user/user.go in runC before 0.1.0, as used in Docker before 1.11.2, improperly treats a numeric UID as a potential username, which allows local users to gain privileges via a numeric username in the password file in a container.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q3j5-32m5-58c2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-3697 Advisory: Privilege Elevation in runc IDs: CVE-2016-3697, GHSA-q3j5-32m5-58c2 Record: https://patchnext.com/advisories/cve-2016-3697 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/opencontainers/runc 0.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/opencontainers/runc: affected < 0.1.0; fixed in 0.1.0 ## Suggested inspection (read-only) - Go github.com/opencontainers/runc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/opencontainers/runc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q3j5-32m5-58c2 (GitHub-reviewed advisory GHSA-q3j5-32m5-58c2 lists affected ranges: Go github.com/opencontainers/runc >=0 <0.1.0) Commands are suggestions: review each one before running it.
Loading voting…