Skip to content

← Actionable
High, CVSS 8.1

Drupal saving user accounts can sometimes grant the user all roles

CVE-2016-3169GHSA-q3p9-8728-wq7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 7.43, 6.38; drupal/drupal 7.43, 6.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 6.0, < 6.38>= 7.0, < 7.43
    Fixed in
    6.38, 7.43
  • Packagist drupal/drupal

    Affected
    >= 7.0, < 7.43>= 6.0, < 6.38
    Fixed in
    6.38, 7.43

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-3169: 2.22% estimated exploitation activity in the next 30 days; percentile 82.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The User module in Drupal 6.x before 6.38 and 7.x before 7.43 allows remote attackers to gain privileges by leveraging contributed or custom code that calls the usersave function with an explicit category and loads all roles into the array.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q3p9-8728-wq7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-3169

Advisory: Drupal saving user accounts can sometimes grant the user all roles
IDs: CVE-2016-3169, GHSA-q3p9-8728-wq7x
Record: https://patchnext.com/advisories/cve-2016-3169 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 7.43, 6.38; drupal/drupal 7.43, 6.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 6.0, < 6.38; >= 7.0, < 7.43; fixed in 6.38, 7.43
- Packagist drupal/drupal: affected >= 7.0, < 7.43; >= 6.0, < 6.38; fixed in 6.38, 7.43

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q3p9-8728-wq7x (GitHub-reviewed advisory GHSA-q3p9-8728-wq7x lists affected ranges: Packagist drupal/core >=6.0 =7.0 =7.0 =6.0 <6.38)

Commands are suggestions: review each one before running it.

Loading voting…