Skip to content

← Actionable
High, CVSS 7.5

Drupal Brute force amplification attacks via XML-RPC

CVE-2016-3163GHSA-h3r9-pjmr-f938

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 7.43, 6.38; drupal/drupal 7.43, 6.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0, < 7.43>= 6.0, < 6.38
    Fixed in
    6.38, 7.43
  • Packagist drupal/drupal

    Affected
    >= 7.0, < 7.43>= 6.0, < 6.38
    Fixed in
    6.38, 7.43

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2016-3163: 1.43% estimated exploitation activity in the next 30 days; percentile 72.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h3r9-pjmr-f938

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-3163

Advisory: Drupal Brute force amplification attacks via XML-RPC
IDs: CVE-2016-3163, GHSA-h3r9-pjmr-f938
Record: https://patchnext.com/advisories/cve-2016-3163 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 7.43, 6.38; drupal/drupal 7.43, 6.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0, < 7.43; >= 6.0, < 6.38; fixed in 6.38, 7.43
- Packagist drupal/drupal: affected >= 7.0, < 7.43; >= 6.0, < 6.38; fixed in 6.38, 7.43

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h3r9-pjmr-f938 (GitHub-reviewed advisory GHSA-h3r9-pjmr-f938 lists affected ranges: Packagist drupal/core >=7.0 =6.0 =7.0 =6.0 <6.38)

Commands are suggestions: review each one before running it.

Loading voting…