Shopware RCE Vulnerability
CVE-2016-3109GHSA-cj2f-96jq-phpp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/shopware 5.1.5, 4.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/shopware
- Affected
- < 4.3.7>= 5.0.0, < 5.1.5
- Fixed in
- 5.1.5, 4.3.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cj2f-96jq-phpp lists affected ranges: Packagist shopware/shopware >=0 =5.0.0 <5.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-3109: 28.11% estimated exploitation activity in the next 30 days; percentile 98.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cj2f-96jq-phpp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-3109 Advisory: Shopware RCE Vulnerability IDs: CVE-2016-3109, GHSA-cj2f-96jq-phpp Record: https://patchnext.com/advisories/cve-2016-3109 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/shopware 5.1.5, 4.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/shopware: affected < 4.3.7; >= 5.0.0, < 5.1.5; fixed in 5.1.5, 4.3.7 ## Suggested inspection (read-only) - Packagist shopware/shopware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/shopware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cj2f-96jq-phpp (GitHub-reviewed advisory GHSA-cj2f-96jq-phpp lists affected ranges: Packagist shopware/shopware >=0 =5.0.0 <5.1.5) Commands are suggestions: review each one before running it.
Loading voting…