Cloud Foundry UAA reset password vulnerable to brute force attack
CVE-2016-3084GHSA-fm5c-2rwc-887w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 3.3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.cloudfoundry.identity:cloudfoundry-identity-server
- Affected
- < 3.3.0.1
- Fixed in
- 3.3.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm5c-2rwc-887w lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 <3.3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-3084: 1.19% estimated exploitation activity in the next 30 days; percentile 67.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The UAA reset password flow in Cloud Foundry release v236 and earlier versions, UAA release v3.3.0 and earlier versions, all versions of Login-server, UAA release v10 and earlier versions and Pivotal Elastic Runtime versions prior to 1.7.2 is vulnerable to a brute force attack due to multiple active codes at a given time. This vulnerability is applicable only when using the UAA internal user store for authentication. Deployments enabled for integration via SAML or LDAP are not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fm5c-2rwc-887w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-3084 Advisory: Cloud Foundry UAA reset password vulnerable to brute force attack IDs: CVE-2016-3084, GHSA-fm5c-2rwc-887w Record: https://patchnext.com/advisories/cve-2016-3084 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 3.3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected < 3.3.0.1; fixed in 3.3.0.1 ## Suggested inspection (read-only) - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fm5c-2rwc-887w (GitHub-reviewed advisory GHSA-fm5c-2rwc-887w lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 <3.3.0.1) Commands are suggestions: review each one before running it.
Loading voting…