Skip to content

← Actionable
Medium, CVSS 4.3

Moodle allows attackers to discover hidden course names

CVE-2016-2154GHSA-fmq9-58q4-xjw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.0.3, 2.9.5, 2.8.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 2.8.0, < 2.8.11>= 2.9.0, < 2.9.5>= 3.0.0, < 3.0.3
    Fixed in
    2.9.5, 3.0.3, 2.8.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2016-2154: 1.69% estimated exploitation activity in the next 30 days; percentile 77.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

admin/tool/monitor/lib.php in Event Monitor in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to discover hidden course names by subscribing to a rule.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fmq9-58q4-xjw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-2154

Advisory: Moodle allows attackers to discover hidden course names
IDs: CVE-2016-2154, GHSA-fmq9-58q4-xjw5
Record: https://patchnext.com/advisories/cve-2016-2154 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.0.3, 2.9.5, 2.8.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 2.8.0, < 2.8.11; >= 2.9.0, < 2.9.5; >= 3.0.0, < 3.0.3; fixed in 2.9.5, 3.0.3, 2.8.11

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fmq9-58q4-xjw5 (GitHub-reviewed advisory GHSA-fmq9-58q4-xjw5 lists affected ranges: Packagist moodle/moodle >=2.8.0 =2.9.0 =3.0.0 <3.0.3)

Commands are suggestions: review each one before running it.

Loading voting…