Skip to content

← Actionable
Critical, CVSS 9.8

Improper Input Validation in JGroups

CVE-2016-2141GHSA-rc7h-x6cq-988q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jgroups:jgroups 3.6.10.Final, 3.2.16.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.jgroups:jgroups

    Affected
    >= 3.3.0.Alpha1, < 3.6.10.Final< 3.2.16.Final
    Fixed in
    3.2.16.Final, 3.6.10.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-2141: 4.70% estimated exploitation activity in the next 30 days; percentile 91.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

JGroups before 4.0 does not require the proper headers for the ENCRYPT and AUTH protocols from nodes joining the cluster, which allows remote attackers to bypass security restrictions and send and receive messages within the cluster via unspecified vectors. Fixes for this issue have been backported to versions 3.6.10.Final and 3.2.16.Final.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rc7h-x6cq-988q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-2141

Advisory: Improper Input Validation in JGroups
IDs: CVE-2016-2141, GHSA-rc7h-x6cq-988q
Record: https://patchnext.com/advisories/cve-2016-2141 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jgroups:jgroups 3.6.10.Final, 3.2.16.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jgroups:jgroups: affected >= 3.3.0.Alpha1, < 3.6.10.Final; < 3.2.16.Final; fixed in 3.2.16.Final, 3.6.10.Final

## Suggested inspection (read-only)
- Maven org.jgroups:jgroups: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jgroups:jgroups.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rc7h-x6cq-988q (GitHub-reviewed advisory GHSA-rc7h-x6cq-988q lists affected ranges: Maven org.jgroups:jgroups >=3.3.0.Alpha1 =0 <3.2.16.Final)

Commands are suggestions: review each one before running it.

Loading voting…