EVP_EncodeUpdate overflow
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 6.1.0, 5.11.1, 4.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 4.0.0, < 4.4.4>= 5.0.0, < 5.11.1>= 6.0.0, < 6.1.0
- Fixed in
- 4.4.4, 6.1.0, 5.11.1
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2016-2105 to 2016-05-05.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 23 lists CVE-2016-2105 affecting node >=4.0.0 =5.0.0 =6.0.0 <6.1.0
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-2105: 39.65% estimated exploitation activity in the next 30 days; percentile 98.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An overflow can occur in the OpenSSL EVP_EncodeUpdate() function which is used for Base64 encoding of binary data. An attacker must be able to supply large amounts of input data in order to cause an overflow. Node.js uses the EVP_EncodeUpdate() internally during calls to crypto.Certificate#exportPublicKey() for SPKAC Certificate Signing Requests. User-supplied data must be passed to this method for applications to be vulnerable. This method has been available since Node.js v0.12.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:23
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-2105 Advisory: EVP_EncodeUpdate overflow IDs: CVE-2016-2105 Record: https://patchnext.com/advisories/cve-2016-2105 (revision 2, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 6.1.0, 5.11.1, 4.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 4.0.0, < 4.4.4; >= 5.0.0, < 5.11.1; >= 6.0.0, < 6.1.0; fixed in 4.4.4, 6.1.0, 5.11.1 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2016-2105 to 2016-05-05.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/23.json (Node.js security working group core entry 23 lists CVE-2016-2105 affecting node >=4.0.0 =5.0.0 =6.0.0 <6.1.0) Commands are suggestions: review each one before running it.
Loading voting…