actionview contains Path Traversal vulnerability
CVE-2016-2097GHSA-vx9j-46rh-fqr8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 4.1.14.2, 3.2.22.2; actionview 4.1.14.2, 3.2.22.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 3.0.0, <= 3.2.22.1>= 4.0.0, <= 4.1.14.1
- Fixed in
- 3.2.22.2, 4.1.14.2
RubyGems actionview
- Affected
- >= 3.0.0, <= 3.2.22.1>= 4.0.0, <= 4.1.14.1
- Fixed in
- 3.2.22.2, 4.1.14.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vx9j-46rh-fqr8 lists affected ranges: RubyGems actionview >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <=4.1.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2016-2097: 4.42% estimated exploitation activity in the next 30 days; percentile 91.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a possible directory traversal and information leak vulnerability in Action View. This was meant to be fixed on CVE-2016-0752. However the 3.2 patch was not covering all possible scenarios. This vulnerability has been assigned the CVE identifier CVE-2016-2097. Versions Affected: 3.2.x, 4.0.x, 4.1.x Not affected: 4.2+ Fixed Versions: 3.2.22.2, 4.1.14.2 Impact ------ Applications that pass unverified user input to the render method in a controller may be vulnerable to an information leak vulnerability. Impacted code will look something like this: Carefully crafted requests can cause the above code to render files from unexpected places like outside the application's view directory, and can possibly escalate this to a remote code execution attack. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases -------- The FIXED releases are available at the normal locations. Workarounds ----------- A workaround to this issue is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vx9j-46rh-fqr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-2097 Advisory: actionview contains Path Traversal vulnerability IDs: CVE-2016-2097, GHSA-vx9j-46rh-fqr8 Record: https://patchnext.com/advisories/cve-2016-2097 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionpack 4.1.14.2, 3.2.22.2; actionview 4.1.14.2, 3.2.22.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 3.0.0, <= 3.2.22.1; >= 4.0.0, <= 4.1.14.1; fixed in 3.2.22.2, 4.1.14.2 - RubyGems actionview: affected >= 3.0.0, <= 3.2.22.1; >= 4.0.0, <= 4.1.14.1; fixed in 3.2.22.2, 4.1.14.2 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. - RubyGems actionview: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack, actionview. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vx9j-46rh-fqr8 (GitHub-reviewed advisory GHSA-vx9j-46rh-fqr8 lists affected ranges: RubyGems actionview >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <=4.1.14.1) Commands are suggestions: review each one before running it.
Loading voting…