Skip to content

← Actionable
Medium, CVSS 5.4

phpMyAdmin XSS Vulnerability

CVE-2016-2040GHSA-pw34-qf6c-84fc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 4.5.4, 4.4.15.3, 4.0.10.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpmyadmin/phpmyadmin

    Affected
    >= 4.0, < 4.0.10.13>= 4.4, < 4.4.15.3>= 4.5, < 4.5.4
    Fixed in
    4.4.15.3, 4.0.10.13, 4.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2016-2040: 1.64% estimated exploitation activity in the next 30 days; percentile 76.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pw34-qf6c-84fc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-2040

Advisory: phpMyAdmin XSS Vulnerability
IDs: CVE-2016-2040, GHSA-pw34-qf6c-84fc
Record: https://patchnext.com/advisories/cve-2016-2040 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 4.5.4, 4.4.15.3, 4.0.10.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.0, < 4.0.10.13; >= 4.4, < 4.4.15.3; >= 4.5, < 4.5.4; fixed in 4.4.15.3, 4.0.10.13, 4.5.4

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pw34-qf6c-84fc (GitHub-reviewed advisory GHSA-pw34-qf6c-84fc lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.0 =4.4 =4.5 <4.5.4)

Commands are suggestions: review each one before running it.

Loading voting…