Skip to content

← Actionable
High, CVSS 7.5

phpMyAdmin Cryptographic Vulnerability

CVE-2016-1927GHSA-4gmg-gwjh-3mmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 4.5.4, 4.4.15.3, 4.0.10.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpmyadmin/phpmyadmin

    Affected
    >= 4.0.0, < 4.0.10.13>= 4.4.0, < 4.4.15.3>= 4.5.0, < 4.5.4
    Fixed in
    4.4.15.3, 4.0.10.13, 4.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2016-1927: 2.69% estimated exploitation activity in the next 30 days; percentile 85.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The suggestPassword function in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the Math.random JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4gmg-gwjh-3mmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-1927

Advisory: phpMyAdmin Cryptographic Vulnerability
IDs: CVE-2016-1927, GHSA-4gmg-gwjh-3mmr
Record: https://patchnext.com/advisories/cve-2016-1927 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 4.5.4, 4.4.15.3, 4.0.10.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.0.0, < 4.0.10.13; >= 4.4.0, < 4.4.15.3; >= 4.5.0, < 4.5.4; fixed in 4.4.15.3, 4.0.10.13, 4.5.4

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4gmg-gwjh-3mmr (GitHub-reviewed advisory GHSA-4gmg-gwjh-3mmr lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.0.0 =4.4.0 =4.5.0 <4.5.4)

Commands are suggestions: review each one before running it.

Loading voting…