Skip to content

← Actionable
Medium, CVSS 4.8

HTTPS MitM vulnerability due to lack of hostname verification

CVE-2016-10932GHSA-9xjr-m6f3-v5wm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyper 0.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io hyper

    Affected
    < 0.9.4
    Fixed in
    0.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2016-10932: 0.74% estimated exploitation activity in the next 30 days; percentile 54.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When used on Windows platforms, all versions of Hyper prior to 0.9.4 did not perform hostname verification when making HTTPS requests. This allows an attacker to perform MitM attacks by preventing any valid CA-issued certificate, even if there's a hostname mismatch. The problem was addressed by leveraging rust-openssl's built-in support for hostname verification.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9xjr-m6f3-v5wm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10932

Advisory: HTTPS MitM vulnerability due to lack of hostname verification
IDs: CVE-2016-10932, GHSA-9xjr-m6f3-v5wm
Record: https://patchnext.com/advisories/cve-2016-10932 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hyper 0.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io hyper: affected < 0.9.4; fixed in 0.9.4

## Suggested inspection (read-only)
- crates.io hyper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9xjr-m6f3-v5wm (GitHub-reviewed advisory GHSA-9xjr-m6f3-v5wm lists affected ranges: crates.io hyper >=0 <0.9.4)

Commands are suggestions: review each one before running it.

Loading voting…