High severity vulnerability that affects org.dspace:dspace-xmlui
CVE-2016-10726GHSA-4m9r-5gqp-7j82
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-xmlui 5.5, 4.5, 3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-xmlui
- Affected
- >= 4.0, < 4.5>= 5.0, < 5.5< 3.6
- Fixed in
- 5.5, 3.6, 4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4m9r-5gqp-7j82 lists affected ranges: Maven org.dspace:dspace-xmlui >=4.0 =5.0 =0 <3.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2016-10726: 2.89% estimated exploitation activity in the next 30 days; percentile 86.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The XMLUI feature in DSpace before 3.6, 4.x before 4.5, and 5.x before 5.5 allows directory traversal via the themes/ path in an attack with two or more arbitrary characters and a colon before a pathname, as demonstrated by a themes/Reference/aa:etc/passwd URI.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4m9r-5gqp-7j82
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10726 Advisory: High severity vulnerability that affects org.dspace:dspace-xmlui IDs: CVE-2016-10726, GHSA-4m9r-5gqp-7j82 Record: https://patchnext.com/advisories/cve-2016-10726 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-xmlui 5.5, 4.5, 3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-xmlui: affected >= 4.0, < 4.5; >= 5.0, < 5.5; < 3.6; fixed in 5.5, 3.6, 4.5 ## Suggested inspection (read-only) - Maven org.dspace:dspace-xmlui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-xmlui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4m9r-5gqp-7j82 (GitHub-reviewed advisory GHSA-4m9r-5gqp-7j82 lists affected ranges: Maven org.dspace:dspace-xmlui >=4.0 =5.0 =0 <3.6) Commands are suggestions: review each one before running it.
Loading voting…