Skip to content

← Actionable
High, CVSS 8.1amended

Downloads Resources over HTTP in nw

CVE-2016-10588GHSA-hv96-xxx2-5v7w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nw 0.23.6-1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nw

    Affected
    <= 0.23.6-sdk
    Fixed in
    0.23.6-1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-10588: 1.73% estimated exploitation activity in the next 30 days; percentile 77.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of nw insecurely download an executable over an unencrypted HTTP connection. In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running nw. Recommendation Update to version 0.23.6-1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hv96-xxx2-5v7w

  2. Revision 1 · created ·

    Published from osv record GHSA-hv96-xxx2-5v7w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10588

Advisory: Downloads Resources over HTTP in nw
IDs: CVE-2016-10588, GHSA-hv96-xxx2-5v7w
Record: https://patchnext.com/advisories/cve-2016-10588 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nw 0.23.6-1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nw: affected <= 0.23.6-sdk; fixed in 0.23.6-1

## Suggested inspection (read-only)
- `npm ls nw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hv96-xxx2-5v7w (OSV record GHSA-hv96-xxx2-5v7w lists affected ranges: npm nw >=0 <0.23.6-1 (fixed))
- Verified: https://github.com/advisories/GHSA-hv96-xxx2-5v7w (GitHub-reviewed advisory GHSA-hv96-xxx2-5v7w lists affected ranges: npm nw >=0 <=0.23.6-sdk)

Commands are suggestions: review each one before running it.

Loading voting…