chromedriver Downloads Resources over HTTP
CVE-2016-10579GHSA-jh5w-6964-x5cf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chromedriver 2.25.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm chromedriver
- Affected
- < 2.25.2
- Fixed in
- 2.25.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jh5w-6964-x5cf lists affected ranges: npm chromedriver >=0 <2.25.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jh5w-6964-x5cf lists affected ranges: npm chromedriver >=0 <2.25.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-10579: 1.10% estimated exploitation activity in the next 30 days; percentile 65.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of chromedriver insecurely download resources over HTTP. In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. This may result in arbitrary code execution if an attacker intercepts and modifies the downloaded binary file, replacing it with a malicious one. Recommendation Update to version 2.26.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jh5w-6964-x5cf
- Revision 1 · created ·
Published from osv record GHSA-jh5w-6964-x5cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10579 Advisory: chromedriver Downloads Resources over HTTP IDs: CVE-2016-10579, GHSA-jh5w-6964-x5cf Record: https://patchnext.com/advisories/cve-2016-10579 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chromedriver 2.25.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm chromedriver: affected < 2.25.2; fixed in 2.25.2 ## Suggested inspection (read-only) - `npm ls chromedriver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chromedriver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jh5w-6964-x5cf (OSV record GHSA-jh5w-6964-x5cf lists affected ranges: npm chromedriver >=0 <2.25.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jh5w-6964-x5cf (GitHub-reviewed advisory GHSA-jh5w-6964-x5cf lists affected ranges: npm chromedriver >=0 <2.25.2) Commands are suggestions: review each one before running it.
Loading voting…