Skip to content

← Actionable
High, CVSS 8.1amended

ibm_db downloads Resources over HTTP

CVE-2016-10577GHSA-c4qp-h3m6-785f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ibm_db 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ibm_db

    Affected
    < 1.0.2
    Fixed in
    1.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-10577: 1.52% estimated exploitation activity in the next 30 days; percentile 74.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of ibmdb insecurely download resources over HTTP. In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution. Recommendation Update to version 1.0.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c4qp-h3m6-785f

  2. Revision 1 · created ·

    Published from osv record GHSA-c4qp-h3m6-785f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10577

Advisory: ibm_db downloads Resources over HTTP
IDs: CVE-2016-10577, GHSA-c4qp-h3m6-785f
Record: https://patchnext.com/advisories/cve-2016-10577 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ibm_db 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ibm_db: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls ibm_db --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ibm_db.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c4qp-h3m6-785f (OSV record GHSA-c4qp-h3m6-785f lists affected ranges: npm ibm_db >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-c4qp-h3m6-785f (GitHub-reviewed advisory GHSA-c4qp-h3m6-785f lists affected ranges: npm ibm_db >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…