Skip to content

← Actionable
High, CVSS 8.1amended

fuseki downloads Resources over HTTP

CVE-2016-10576GHSA-3627-w2qr-5fxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuseki 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fuseki

    Affected
    < 1.0.1
    Fixed in
    1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2016-10576: 1.66% estimated exploitation activity in the next 30 days; percentile 76.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of fuseki insecurely download an executable over an unencrypted HTTP connection. In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running fuseki. Recommendation Update to version 1.0.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3627-w2qr-5fxr

  2. Revision 1 · created ·

    Published from osv record GHSA-3627-w2qr-5fxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10576

Advisory: fuseki downloads Resources over HTTP
IDs: CVE-2016-10576, GHSA-3627-w2qr-5fxr
Record: https://patchnext.com/advisories/cve-2016-10576 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuseki 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuseki: affected < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- `npm ls fuseki --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuseki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3627-w2qr-5fxr (OSV record GHSA-3627-w2qr-5fxr lists affected ranges: npm fuseki >=0 <1.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3627-w2qr-5fxr (GitHub-reviewed advisory GHSA-3627-w2qr-5fxr lists affected ranges: npm fuseki >=0 <1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…