Downloads Resources over HTTP in bkjs-wand
CVE-2016-10571GHSA-4wm5-q7wv-6jx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bkjs-wand 0.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm bkjs-wand
- Affected
- < 0.3.2
- Fixed in
- 0.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4wm5-q7wv-6jx3 lists affected ranges: npm bkjs-wand >=0 <0.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4wm5-q7wv-6jx3 lists affected ranges: npm bkjs-wand >=0 <0.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10571: 1.66% estimated exploitation activity in the next 30 days; percentile 76.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of bkjs-wand insecurely download an executable over an unencrypted HTTP connection. In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running bkjs-wand. Recommendation Update to version 0.3.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4wm5-q7wv-6jx3
- Revision 1 · created ·
Published from osv record GHSA-4wm5-q7wv-6jx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10571 Advisory: Downloads Resources over HTTP in bkjs-wand IDs: CVE-2016-10571, GHSA-4wm5-q7wv-6jx3 Record: https://patchnext.com/advisories/cve-2016-10571 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bkjs-wand 0.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm bkjs-wand: affected < 0.3.2; fixed in 0.3.2 ## Suggested inspection (read-only) - `npm ls bkjs-wand --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bkjs-wand. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4wm5-q7wv-6jx3 (OSV record GHSA-4wm5-q7wv-6jx3 lists affected ranges: npm bkjs-wand >=0 <0.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4wm5-q7wv-6jx3 (GitHub-reviewed advisory GHSA-4wm5-q7wv-6jx3 lists affected ranges: npm bkjs-wand >=0 <0.3.2) Commands are suggestions: review each one before running it.
Loading voting…