Downloads Resources over HTTP in apk-parser
CVE-2016-10564GHSA-5g4r-87v2-jqvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apk-parser 0.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apk-parser
- Affected
- < 0.1.6
- Fixed in
- 0.1.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5g4r-87v2-jqvx lists affected ranges: npm apk-parser >=0 <0.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5g4r-87v2-jqvx lists affected ranges: npm apk-parser >=0 <0.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10564: 1.10% estimated exploitation activity in the next 30 days; percentile 65.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
apk-parser is a tool to extract Android Manifest info from an APK file. apk-parser versions below 0.1.6 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server. Recommendation Update to version 0.1.6 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5g4r-87v2-jqvx
- Revision 1 · created ·
Published from osv record GHSA-5g4r-87v2-jqvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10564 Advisory: Downloads Resources over HTTP in apk-parser IDs: CVE-2016-10564, GHSA-5g4r-87v2-jqvx Record: https://patchnext.com/advisories/cve-2016-10564 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apk-parser 0.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apk-parser: affected < 0.1.6; fixed in 0.1.6 ## Suggested inspection (read-only) - `npm ls apk-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apk-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5g4r-87v2-jqvx (OSV record GHSA-5g4r-87v2-jqvx lists affected ranges: npm apk-parser >=0 <0.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-5g4r-87v2-jqvx (GitHub-reviewed advisory GHSA-5g4r-87v2-jqvx lists affected ranges: npm apk-parser >=0 <0.1.6) Commands are suggestions: review each one before running it.
Loading voting…