Skip to content

← Actionable
High, CVSS 7.5amended

SQL Injection in sequelize

CVE-2016-10556GHSA-9c2p-jw8p-f84v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 3.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2016-10556: 1.32% estimated exploitation activity in the next 30 days; percentile 70.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of sequelize cast arrays to strings and fail to properly escape the resulting SQL statement, resulting in a SQL injection vulnerability. Proof of Concept In Postgres, SQLite, and Microsoft SQL Server there is an issue where arrays are treated as strings and improperly escaped. Example Query: If the user inputs the value of :names as: The resulting SQL statement will be: As the backslash has no special meaning in PostgreSQL, MSSQL, or SQLite, the statement will delete the record in TestTable with an Id of 1. Recommendation Update to version 3.20.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9c2p-jw8p-f84v

  2. Revision 1 · created ·

    Published from osv record GHSA-9c2p-jw8p-f84v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10556

Advisory: SQL Injection in sequelize
IDs: CVE-2016-10556, GHSA-9c2p-jw8p-f84v
Record: https://patchnext.com/advisories/cve-2016-10556 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sequelize 3.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize: affected <= 3.19.3; fixed in 3.20.0

## Suggested inspection (read-only)
- `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9c2p-jw8p-f84v (OSV record GHSA-9c2p-jw8p-f84v lists affected ranges: npm sequelize >=0 <3.20.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9c2p-jw8p-f84v (GitHub-reviewed advisory GHSA-9c2p-jw8p-f84v lists affected ranges: npm sequelize >=0 <=3.19.3)

Commands are suggestions: review each one before running it.

Loading voting…