Skip to content

← Actionable
Unratedamended

SQL Injection in sequelize

CVE-2016-10554GHSA-x2jc-pwfj-h9p3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 1.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sequelize

    Affected
    <= 1.7.0-alpha2
    Fixed in
    1.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2016-10554: 1.88% estimated exploitation activity in the next 30 days; percentile 79.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of sequelize use MySQL's backslash-based escape syntax when connecting to SQLite, despite the fact that SQLite uses PostgreSQL's escape syntax, which can result in a SQL Injection vulnerability. Recommendation Update to version 1.7.0-alpha3 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x2jc-pwfj-h9p3

  2. Revision 1 · created ·

    Published from osv record GHSA-x2jc-pwfj-h9p3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10554

Advisory: SQL Injection in sequelize
IDs: CVE-2016-10554, GHSA-x2jc-pwfj-h9p3
Record: https://patchnext.com/advisories/cve-2016-10554 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sequelize 1.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize: affected <= 1.7.0-alpha2; fixed in 1.7.0

## Suggested inspection (read-only)
- `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x2jc-pwfj-h9p3 (OSV record GHSA-x2jc-pwfj-h9p3 lists affected ranges: npm sequelize >=0 <1.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x2jc-pwfj-h9p3 (GitHub-reviewed advisory GHSA-x2jc-pwfj-h9p3 lists affected ranges: npm sequelize >=0 <=1.7.0-alpha2)

Commands are suggestions: review each one before running it.

Loading voting…