Sails before 0.12.7 vulnerable to Broken CORS
CVE-2016-10549GHSA-qmv4-jgp7-mf68
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sails 0.12.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sails
- Affected
- < 0.12.7
- Fixed in
- 0.12.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmv4-jgp7-mf68 lists affected ranges: npm sails >=0 <0.12.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmv4-jgp7-mf68 lists affected ranges: npm sails >=0 <0.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10549: 0.64% estimated exploitation activity in the next 30 days; percentile 50.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of sails have an issue with the CORS configuration where the value of the origin header is reflected as the value for the Access-Control-Allow-Origin header. This may allow an attacker to make AJAX requests to vulnerable hosts through cross-site scripting or a malicious HTML Document, effectively bypassing the Same Origin Policy. Mitigating Factors This is only an issue when allRoutes is set to true and origin is set to or left commented out in the sails CORS config file. The problem can be compounded when the cors credentials setting is not provided, because at that point authenticated cross domain requests are possible. Recommendation Update to version 0.12.7 or later. As this vulnerability is primarily a user error, the patch for the vulnerability will simply cause the application to write an error message to the console when a vulnerable configuration is used in a production environment. Writing a proper CORS configuration is still the responsibility of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qmv4-jgp7-mf68
- Revision 1 · created ·
Published from osv record GHSA-qmv4-jgp7-mf68
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10549 Advisory: Sails before 0.12.7 vulnerable to Broken CORS IDs: CVE-2016-10549, GHSA-qmv4-jgp7-mf68 Record: https://patchnext.com/advisories/cve-2016-10549 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sails 0.12.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sails: affected < 0.12.7; fixed in 0.12.7 ## Suggested inspection (read-only) - `npm ls sails --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmv4-jgp7-mf68 (OSV record GHSA-qmv4-jgp7-mf68 lists affected ranges: npm sails >=0 <0.12.7 (fixed)) - Verified: https://github.com/advisories/GHSA-qmv4-jgp7-mf68 (GitHub-reviewed advisory GHSA-qmv4-jgp7-mf68 lists affected ranges: npm sails >=0 <0.12.7) Commands are suggestions: review each one before running it.
Loading voting…