Denial of Service in uws
CVE-2016-10544GHSA-hf5h-hh56-3vrg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uws 0.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm uws
- Affected
- >= 0.10.0, <= 0.10.8
- Fixed in
- 0.10.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hf5h-hh56-3vrg lists affected ranges: npm uws >=0.10.0 <0.10.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf5h-hh56-3vrg lists affected ranges: npm uws >=0.10.0 <=0.10.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10544: 1.32% estimated exploitation activity in the next 30 days; percentile 70.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of uws do not properly handle large websocket messages when permessage-deflate is enabled, which may result in a denial of service condition. If uws recieves a 256Mb websocket message when permessage-deflate is enabled, the server will compress the message prior to executing the length check, and subsequently extract the message prior to processing. This can result in a situation where an excessively large websocket message passes the length checks, yet still gets cast from a Buffer to a string, which will exceed v8's maximum string size and crash the process. Recommendation Update to version 0.10.9 or later. Alternatively, disable permessage-deflate.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hf5h-hh56-3vrg
- Revision 1 · created ·
Published from osv record GHSA-hf5h-hh56-3vrg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10544 Advisory: Denial of Service in uws IDs: CVE-2016-10544, GHSA-hf5h-hh56-3vrg Record: https://patchnext.com/advisories/cve-2016-10544 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uws 0.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm uws: affected >= 0.10.0, <= 0.10.8; fixed in 0.10.9 ## Suggested inspection (read-only) - `npm ls uws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hf5h-hh56-3vrg (OSV record GHSA-hf5h-hh56-3vrg lists affected ranges: npm uws >=0.10.0 <0.10.9 (fixed)) - Verified: https://github.com/advisories/GHSA-hf5h-hh56-3vrg (GitHub-reviewed advisory GHSA-hf5h-hh56-3vrg lists affected ranges: npm uws >=0.10.0 <=0.10.8) Commands are suggestions: review each one before running it.
Loading voting…