Arbitrary File Write in cli
CVE-2016-10538GHSA-6cpc-mj5c-m9rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cli 1.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm cli
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6cpc-mj5c-m9rq lists affected ranges: npm cli >=0 <1.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6cpc-mj5c-m9rq lists affected ranges: npm cli >=0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10538: 0.98% estimated exploitation activity in the next 30 days; percentile 62.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of cli use predictable temporary file names. If an attacker can create a symbolic link at the location of one of these temporarly file names, the attacker can arbitrarily write to any file that the user which owns the cli process has permission to write to. Proof of Concept By creating Symbolic Links at the following locations, the target of the link can be written to. Recommendation Update to version 1.0.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6cpc-mj5c-m9rq
- Revision 1 · created ·
Published from osv record GHSA-6cpc-mj5c-m9rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10538 Advisory: Arbitrary File Write in cli IDs: CVE-2016-10538, GHSA-6cpc-mj5c-m9rq Record: https://patchnext.com/advisories/cve-2016-10538 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cli 1.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm cli: affected < 1.0.0; fixed in 1.0.0 ## Suggested inspection (read-only) - `npm ls cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6cpc-mj5c-m9rq (OSV record GHSA-6cpc-mj5c-m9rq lists affected ranges: npm cli >=0 <1.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6cpc-mj5c-m9rq (GitHub-reviewed advisory GHSA-6cpc-mj5c-m9rq lists affected ranges: npm cli >=0 <1.0.0) Commands are suggestions: review each one before running it.
Loading voting…