Skip to content

← Actionable
Medium, CVSS 5.9amended

Insecure Defaults Allow MITM Over TLS in engine.io-client

CVE-2016-10536GHSA-4r4m-hjwj-43p8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (engine.io-client 1.6.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2016-10536: 1.00% estimated exploitation activity in the next 30 days; percentile 62.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of engine.io-client do not verify certificates by default, and as such may be vulnerable to Man-in-the-Middle attacks. The vulnerability is related to the way that node.js handles the rejectUnauthorized setting. If the value is something that evaluates to false, such as undefined or null, certificate verification will be disabled. Recommendation Update to version 1.6.9 or later. If you are unable to upgrade, ensure all calls to socket.io to have a rejectedUnauthorized: true flag.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4r4m-hjwj-43p8

  2. Revision 1 · created ·

    Published from osv record GHSA-4r4m-hjwj-43p8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10536

Advisory: Insecure Defaults Allow MITM Over TLS in engine.io-client
IDs: CVE-2016-10536, GHSA-4r4m-hjwj-43p8
Record: https://patchnext.com/advisories/cve-2016-10536 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: engine.io-client 1.6.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm engine.io-client: affected < 1.6.9; fixed in 1.6.9

## Suggested inspection (read-only)
- `npm ls engine.io-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on engine.io-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r4m-hjwj-43p8 (OSV record GHSA-4r4m-hjwj-43p8 lists affected ranges: npm engine.io-client >=0 <1.6.9 (fixed))
- Verified: https://github.com/advisories/GHSA-4r4m-hjwj-43p8 (GitHub-reviewed advisory GHSA-4r4m-hjwj-43p8 lists affected ranges: npm engine.io-client >=0 <1.6.9)

Commands are suggestions: review each one before running it.

Loading voting…