Skip to content

← Actionable
Unratedamended

Timing Attack in csrf-lite

CVE-2016-10535GHSA-hjhr-r3gq-qvp6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (csrf-lite 0.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2016-10535: 1.28% estimated exploitation activity in the next 30 days; percentile 70.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of csrf-lite are vulnerable to timing attacks as a result of testing CSRF tokens via a fail-early comparison instead of a constant-time comparison. Timing attacks remove the exponential increase in entropy gained from increased secret length, by providing per-character feedback on the correctness of a guess via miniscule timing differences. Under favorable network conditions, an attacker can exploit this to guess the secret in no more than (1618)288 guesses, instead of the 16^18 guesses required were the timing attack not present. Recommendation Update to version 0.1.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hjhr-r3gq-qvp6

  2. Revision 1 · created ·

    Published from osv record GHSA-hjhr-r3gq-qvp6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10535

Advisory: Timing Attack in csrf-lite
IDs: CVE-2016-10535, GHSA-hjhr-r3gq-qvp6
Record: https://patchnext.com/advisories/cve-2016-10535 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: csrf-lite 0.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm csrf-lite: affected < 0.1.2; fixed in 0.1.2

## Suggested inspection (read-only)
- `npm ls csrf-lite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on csrf-lite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hjhr-r3gq-qvp6 (OSV record GHSA-hjhr-r3gq-qvp6 lists affected ranges: npm csrf-lite >=0 <0.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hjhr-r3gq-qvp6 (GitHub-reviewed advisory GHSA-hjhr-r3gq-qvp6 lists affected ranges: npm csrf-lite >=0 <0.1.2)

Commands are suggestions: review each one before running it.

Loading voting…