SSL Validation Defaults to False in electron-packager
CVE-2016-10534GHSA-q43m-ffwr-rpcc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron-packager 7.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 5.2.1, < 7.0.0
- Fixed in
- 7.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q43m-ffwr-rpcc lists affected ranges: npm electron-packager >=5.2.1 <7.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q43m-ffwr-rpcc lists affected ranges: npm electron-packager >=5.2.1 <7.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10534: 0.94% estimated exploitation activity in the next 30 days; percentile 60.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of electron-packager configure the generated application to disable SSL certificate verification by default. This could allow an attacker with a privileged network position to launch a Man In The Middle (MITM) attack on the install process, intercepting the step where electron-packager downloads Electron for supported target platforms and architectures, and replacing the valid download with a tampered malicious one. This only affects users using the electron-packager CLI. The strict-ssl option defaults to true for the node.js API. Recommendation 1. Update to version 7.0.0 or later. 2. Delete the electron-download cache folder, which is by default located at ~/.electron.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q43m-ffwr-rpcc
- Revision 1 · created ·
Published from osv record GHSA-q43m-ffwr-rpcc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10534 Advisory: SSL Validation Defaults to False in electron-packager IDs: CVE-2016-10534, GHSA-q43m-ffwr-rpcc Record: https://patchnext.com/advisories/cve-2016-10534 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron-packager 7.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron-packager: affected >= 5.2.1, < 7.0.0; fixed in 7.0.0 ## Suggested inspection (read-only) - `npm ls electron-packager --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron-packager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q43m-ffwr-rpcc (OSV record GHSA-q43m-ffwr-rpcc lists affected ranges: npm electron-packager >=5.2.1 <7.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q43m-ffwr-rpcc (GitHub-reviewed advisory GHSA-q43m-ffwr-rpcc lists affected ranges: npm electron-packager >=5.2.1 <7.0.0) Commands are suggestions: review each one before running it.
Loading voting…