Private Data Disclosure in express-restify-mongoose
CVE-2016-10533GHSA-cgjx-mwpx-47jv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-restify-mongoose 3.1.0, 2.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.4.2>= 3.0.0, <= 3.0.1
- Fixed in
- 3.1.0, 2.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cgjx-mwpx-47jv lists affected ranges: npm express-restify-mongoose >=3.0.0 =0 <2.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgjx-mwpx-47jv lists affected ranges: npm express-restify-mongoose >=0 =3.0.0 <=3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10533: 1.40% estimated exploitation activity in the next 30 days; percentile 72.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of express-restify-mongoose are susceptible to an information leakage vulnerability which may allow an attacker to access fields on a model even if those fields are marked as private. Proof of Concept If you have a user model that you want to protect, such as the following User model: You would normally do something such as: This would hide the password field from people that send your application a GET /User and GET /User/some-user-id request. A malicious user can go to your application and send a request for GET /User?distinct=password and get all the passwords for all the users in the database, despite the field being set to private. This could be used for other private data, if the malicious user knew what was set as private for specific routes. Recommendation Version 2.x: Update to version 2.5.0 or later. Version 3.x: Update to version 3.1.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cgjx-mwpx-47jv
- Revision 1 · created ·
Published from osv record GHSA-cgjx-mwpx-47jv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10533 Advisory: Private Data Disclosure in express-restify-mongoose IDs: CVE-2016-10533, GHSA-cgjx-mwpx-47jv Record: https://patchnext.com/advisories/cve-2016-10533 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-restify-mongoose 3.1.0, 2.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-restify-mongoose: affected <= 2.4.2; >= 3.0.0, <= 3.0.1; fixed in 3.1.0, 2.5.0 ## Suggested inspection (read-only) - `npm ls express-restify-mongoose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-restify-mongoose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cgjx-mwpx-47jv (OSV record GHSA-cgjx-mwpx-47jv lists affected ranges: npm express-restify-mongoose >=3.0.0 =0 <2.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cgjx-mwpx-47jv (GitHub-reviewed advisory GHSA-cgjx-mwpx-47jv lists affected ranges: npm express-restify-mongoose >=0 =3.0.0 <=3.0.1) Commands are suggestions: review each one before running it.
Loading voting…