Directory Traversal in restafary
CVE-2016-10528GHSA-xg5r-8j97-2wrj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (restafary 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm restafary
- Affected
- < 1.6.1
- Fixed in
- 1.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xg5r-8j97-2wrj lists affected ranges: npm restafary >=0 <1.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xg5r-8j97-2wrj lists affected ranges: npm restafary >=0 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2016-10528: 1.18% estimated exploitation activity in the next 30 days; percentile 67.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of restafary are susceptible to a directory traversal vulnerability when a root path is specified in the configuration. Proof of Concept Recommendation Update to version 1.6.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xg5r-8j97-2wrj
- Revision 1 · created ·
Published from osv record GHSA-xg5r-8j97-2wrj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-10528 Advisory: Directory Traversal in restafary IDs: CVE-2016-10528, GHSA-xg5r-8j97-2wrj Record: https://patchnext.com/advisories/cve-2016-10528 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: restafary 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm restafary: affected < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - `npm ls restafary --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on restafary. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xg5r-8j97-2wrj (OSV record GHSA-xg5r-8j97-2wrj lists affected ranges: npm restafary >=0 <1.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xg5r-8j97-2wrj (GitHub-reviewed advisory GHSA-xg5r-8j97-2wrj lists affected ranges: npm restafary >=0 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…