Skip to content

← Actionable
Unratedamended

grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file

CVE-2016-10526GHSA-rrj3-qmh8-72pf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (grunt-gh-pages 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2016-10526: 1.61% estimated exploitation activity in the next 30 days; percentile 75.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of grunt-gh-pages prior to 0.10.0 are affected by a vulnerability which may cause unencrypted GitHub credentials to be written to a log file in certain circumstances. In the grunt-gh-pages deployment scenario where authentication is performed by injecting a GitHub token directly into the auth portion of the URL, grunt-gh-pages will write the token to a log file, unencrypted. Recommendation Update to version 0.10.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rrj3-qmh8-72pf

  2. Revision 1 · created ·

    Published from osv record GHSA-rrj3-qmh8-72pf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10526

Advisory: grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file
IDs: CVE-2016-10526, GHSA-rrj3-qmh8-72pf
Record: https://patchnext.com/advisories/cve-2016-10526 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: grunt-gh-pages 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm grunt-gh-pages: affected <= 0.9.1; fixed in 0.10.0

## Suggested inspection (read-only)
- `npm ls grunt-gh-pages --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on grunt-gh-pages.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rrj3-qmh8-72pf (OSV record GHSA-rrj3-qmh8-72pf lists affected ranges: npm grunt-gh-pages >=0 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rrj3-qmh8-72pf (GitHub-reviewed advisory GHSA-rrj3-qmh8-72pf lists affected ranges: npm grunt-gh-pages >=0 <=0.9.1)

Commands are suggestions: review each one before running it.

Loading voting…